All files / app/assets/javascripts/jira_connect/subscriptions/components browser_support_alert.vue

100% Statements 1/1
100% Branches 0/0
100% Functions 1/1
100% Lines 1/1

Press n or j to go to the next uncovered block, b, p or k for the previous block.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31                                          14x                  
<script>
import { GlAlert, GlSprintf, GlLink } from '@gitlab/ui';
import { s__ } from '~/locale';
import { helpPagePath } from '~/helpers/help_page_helper';
 
export default {
  name: 'BrowserSupportAlert',
  components: {
    GlAlert,
    GlSprintf,
    GlLink,
  },
  i18n: {
    title: s__('Integrations|Your browser is not supported'),
    body: s__(
      'Integrations|You must use a %{linkStart}supported browser%{linkEnd} to use the GitLab for Jira app.',
    ),
  },
  DOCS_LINK_URL: helpPagePath('install/requirements', { anchor: 'supported-web-browsers' }),
};
</script>
<template>
  <gl-alert variant="danger" :title="$options.i18n.title" :dismissible="false">
    <gl-sprintf :message="$options.i18n.body">
      <template #link="{ content }">
        <gl-link :href="$options.DOCS_LINK_URL" target="_blank">{{ content }}</gl-link>
      </template>
    </gl-sprintf>
  </gl-alert>
</template>